{"id":"SUSE-SU-2026:20927-1","summary":"Security update for 389-ds","details":"This update for 389-ds fixes the following issue:\n\nUpdate to 389-ds 3.0.6~git249.6688af9b2:\n\n- CVE-2025-14905: heap buffer overflow due to improper size calculation in `schema_attr_enum_callback` can lead to DoS\n  and RCE (bsc#1258727).\n\nChangelog:\n\n * Issue 7277 - UI - Fix Japanese translation for \"Successfully updated group\" in Cockpit UI (#7278)\n * Issue 7275 - UI - Improve password policy field validation in Cockpit UI (#7276)\n * Issue 7279 - UI - Fix typo in export certificate dialog (#7280)\n * Issue 7273 - In a chaining environment binding as remote user causes an invalid error in the logs\n * Issue 7271 - plugins that create threads need to update active thread count\n * Issue 5853 - Update concread to 0.5.10\n * Issue 7053 - Remove memberof_del_dn_from_groups from MemberOf plugin (#7064)\n * Issue 7223 - Remove integerOrderingMatch requirement for parentid (#7264)\n * Issue 7066/7052 - allow password history to be set to zero and remove history\n * Issue 7223 - Use lexicographical order for ancestorid (#7256)\n * Issue 7213 - (2nd) MDB_BAD_VALSIZE error while handling VLV (#7258)\n * Issue 7184 - (2nd) argparse.HelpFormatter _format_actions_usage() is deprecated (#7257)\n * Issue - CLI - dsctl db2index needs some hardening with MBD\n * Issue 7248 - CLI - attribute uniqueness - fix usage for exclude subtree option\n * Issue 7231 - Sync repl tests fail in FIPS mode due to non FIPS compliant crypto (#7232)\n * Issue 7121 - (2nd) LeakSanitizer: various leaks during replication (#7212)\n * Issue 6947 - Fix health_system_indexes_test.py\n * Issue 7076 - Fix revert_cache() never called in modrdn (#7220)\n * Issue 7076, 6992, 6784, 6214 - Fix CI test failures (#7077)\n * Issue 7096 - (2nd) During replication online total init the function idl_id_is_in_idlist is not scaling with large\n   database (#7205)\n * Issue 3555 - UI - Fix audit issue with npm - @isaacs/brace-expansion (#7228)\n * Issue 7223 - Add dsctl index-check command for offline index repair\n * Issue 7223 - Detect and log index ordering mismatch during backend startup\n * Issue 7223 - Add upgrade function to remove ancestorid index config entry\n * Issue 7223 - Add upgrade function to remove nsIndexIDListScanLimit from parentid\n * Issue 7223 - Revert index scan limits for system indexes\n * Issue 6542 - RPM build errors on Fedora 42\n * Issue 7224 - CI Test - Simplify test_reserve_descriptor_validation (#7225)\n * Issue 7194 - Repl Log Analysis - Add CSN propagation details (#7195)\n * Issue 7213 - MDB_BAD_VALSIZE error while handling VLV (#7214)\n * Issue 7027 - (2nd) 389-ds-base OpenScanHub Leaks Detected (#7211)\n * Issue 7184 - argparse.HelpFormatter _format_actions_usage() is deprecated\n * Issue 7198 - Web console doesn't show sub-suffix when parent-suffix points to an entry (#7202)\n * Issue 7189 - DSBLE0007 generates incorrect remediation commands for scan limits\n * Bump lodash from 4.17.21 to 4.17.23 in /src/cockpit/389-console (#7203)\n * Issue 7172 - (2nd) Index ordering mismatch after upgrade (#7180)\n * Issue 7172 - Index ordering mismatch after upgrade (#7173)\n * Issue - Revise paged result search locking\n * Issue 7096 - During replication online total init the function idl_id_is_in_idlist is not scaling with large\n   database (#7145)\n * Revert \"Issue 7160 - Add lib389 version sync check to configure (#7165)\"\n * Issue 7160 - Add lib389 version sync check to configure (#7165)\n * Issue 7049 - RetroCL plugin generates invalid LDIF\n * Issue 7150 - Compressed access log rotations skipped, accesslog-list out of sync (#7151)\n * Restore definition for slapi_entry_attr_get_valuearray\n * Issue 1793 - RFE - Dynamic lists - UI and CLI updates\n * Issue 7119 - Fix DNA shared config replication test (#7143)\n * Issue 7081 - Repl Log Analysis - Implement data sampling with performance and timezone fixes (#7086)\n * Issue 1793 - RFE - Implement dynamic lists\n * Issue 6753 - Port ticket tests\n * Issue 6753 - Port and fix ticket 47823 tests\n * Issue 6753 - Add 'add_exclude_subtree' and 'remove_exclude_subtree' methods to Attribute uniqueness plugin\n * Issue 6753 - Port ticket test 48026\n * Issue 7128 - memory corruption in alias entry plugin (#7131)\n * Issue 7091 - Duplicate local password policy entries listed (#7092)\n * Issue 7124 - BDB cursor race condition with transaction isolation (#7125)\n * Issue 7132 - Keep alive entry updated too soon after an offline import (#7133)\n * Issue 7121 - LeakSanitizer: various leaks during replication (#7122)\n * Issue 7115 - LeakSanitizer: leak in `slapd_bind_local_user()` (#7116)\n * Issue 7109 - AddressSanitizer: SEGV ldap/servers/slapd/csnset.c:302 in csnset_dup (#7114)\n * Issue 7056 - DSBLE0007 doesn't generate remediation steps for missing indexes\n * Issue 7119 - Harden DNA plugin locking for shared server list operations (#7120)\n * Issue 7084 - UI - schema - sorting attributes breaks expanded row\n * Issue 7007 - Improve paged result search locking\n * Issue 3555 - UI - Fix audit issue with npm - glob (#7107)\n * Issue 6846 - Attribute uniqueness is not enforced with modrdn (#7026)\n * Issue 6901 - Update changelog trimming logging - fix tests\n * Issue 6901 - Update changelog trimming logging\n * Bump js-yaml from 4.1.0 to 4.1.1 in /src/cockpit/389-console (#7097)\n * Issue 7069 - Fix error reporting in HAProxy trusted IP parsing (#7094)\n * Issue 7055 - Online initialization of consumers fails with error -23 (#7075)\n * Issue 7042 - Enable global_backend_lock when memberofallbackend is enabled (#7043)\n * Issue 7078 - audit json logging does not encode binary values\n * Issue 7069 - Add Subnet/CIDR Support for HAProxy Trusted IPs (#7070)\n * Issue 6660 - CLI, UI - Improve replication log analyzer usability (#7062)\n * Issue 7065 - A search filter containing a non normalized DN assertion does not return matching entries (#7068)\n * Issue 7071 - search filter (&(cn:dn:=groups)) no longer returns results\n * Issue 7073 - Add NDN cache size configuration and enforcement tests (#7074)\n * Issue 7041 - CLI/UI - memberOf - no way to add/remove specific group filters\n * Issue 7061 - CLI/UI - Improve error messages for dsconf localpwp list\n * Issue 7059 - UI - unable to upload pem file\n * Issue 7032 - The new ipahealthcheck test ipahealthcheck.ds.backends.BackendsCheck raises CRITICAL issue (#7036)\n * Issue 7047 - MemberOf plugin logs null attribute name on fixup task completion (#7048)\n * Issue 7044 - RFE - index sudoHost by default (#7046)\n * Issue 6979 - Improve the way to detect asynchronous operations in the access logs (#6980)\n * Issue 7035 - RFE - memberOf - adding scoping for specific groups\n * Issue - CLI/UI - Add option to delete all replication conflict entries\n * Issue 7033 - lib389 - basic plugin status not in JSON\n * Issue 7023 - UI - if first instance that is loaded is stopped it breaks parts of the UI\n * Issue 7027 - 389-ds-base OpenScanHub Leaks Detected (#7028)\n * Issue 6966 - On large DB, unlimited IDL scan limit reduce the SRCH performance (#6967)\n * Issue 6660 - UI - Improve replication log analysis charts and usability (#6968)\n * Issue 6982 - UI - MemberOf shared config does not validate DN properly (#6983)\n * Issue 7021 - Units for changing MDB max size are not consistent across different tools (#7022)\n * Issue 6954 - do not delete referrals on chain_on_update backend\n * Issue 7018 - BUG - prevent stack depth being hit (#7019)\n * Issue 6928 - The parentId attribute is indexed with improper matching rule\n * Issue 6933 - When deferred memberof update is enabled after the server crashed it should not launch memberof fixup\n   task by default (#6935)\n * Issue 6904 - Fix config_test.py::test_lmdb_config\n * Issue 7014 - memberOf - ignored deferred updates with LMDB\n * Issue 7012 - improve dscrl dbverify result when backend does not exists (#7013)\n * Issue 6929 - Compilation failure with rust-1.89 on Fedora ELN\n * Issue 6990 - UI - Replace deprecated Select components with new TypeaheadSelect (#6996)\n * Issue 6990 - UI - Fix typeahead Select fields losing values on Enter keypress (#6991)\n * Issue 6887 - Enhance logconv.py to add support for JSON access logs (#6889)\n * Issue 6985 - Some logconv CI tests fail with BDB (#6986)\n * Issue 6891 - JSON logging - add wrapper function that checks for NULL\n * Issue 6977 - UI - Show error message when trying to use unavailable ports (#6978)\n * Issue 6956 - More UI fixes\n * Issue 6947 - Revise time skew check in healthcheck tool and add option to exclude checks\n * Issue 6805 - RFE - Multiple backend entry cache tuning\n * Issue 6843 - Add CI tests for logconv.py (#6856)\n * Issue - UI - update Radio handlers and LDAP entries last modified time\n * Issue 6660 - UI - Fix minor typo (#6955)\n * Issue 6910 - Fix latest coverity issues\n * Issue 6919 - numSubordinates/tombstoneNumSubordinates are inconsisten... (#6920)\n * Issue 6663 - Fix NULL subsystem crash in JSON error logging (#6883)\n * Issue 6940 - dsconf monitor server fails with ldapi:// due to absent server ID (#6941)\n * Issue 6936 - Make user/subtree policy creation idempotent (#6937)\n * Issue 6865 - AddressSanitizer: leak in agmt_update_init_status\n * Issue 6848 - AddressSanitizer: leak in do_search\n * Issue 6850 - AddressSanitizer: memory leak in mdb_init\n * Issue 6778 - Memory leak in roles_cache_create_object_from_entry part 2\n * Issue 6778 - Memory leak in roles_cache_create_object_from_entry\n * Issue 6181 - RFE - Allow system to manage uid/gid at startup\n * Issues 6913, 6886, 6250 - Adjust xfail marks (#6914)\n * Issue 6768 - ns-slapd crashes when a referral is added (#6780)\n * Issue 6468 - CLI - Fix default error log level\n * Issue 6339 - Address Coverity scan issues in memberof and bdb_layer (#6353)\n * Issue 6897 - Fix disk monitoring test failures and improve test maintainability (#6898)\n * Issue 6884 - Mask password hashes in audit logs (#6885)\n * Issue 6594 - Add test for numSubordinates replication consistency with tombstones (#6862)\n * Issue 6250 - Add test for entryUSN overflow on failed add operations (#6821)\n * Issue 6895 - Crash if repl keep alive entry can not be created\n * Issue 6893 - Log user that is updated during password modify extended operation\n * Issue 6772 - dsconf - Replicas with the \"consumer\" role allow for viewing and modification of their\n   changelog. (#6773)\n * Issue 6888 - Missing access JSON logging for TLS/Client auth\n * Issue 6680 - instance read-only mode is broken (#6681)\n * Issue 6878 - Prevent repeated disconnect logs during shutdown (#6879)\n * Issue 6872 - compressed log rotation creates files with world readable permission\n * Issue 6859 - str2filter is not fully applying matching rules\n * Issue 6868 - UI - schema attribute table expansion break after moving to a new page\n * Issue 6854 - Refactor for improved data management (#6855)\n * Issue 6756 - CLI, UI - Properly handle disabled NDN cache (#6757)\n * Issue 6857 - uiduniq: allow specifying match rules in the filter\n * Issue 6838 - lib389/replica.py is using nonexistent datetime.UTC in Python 3.9\n * Issue 6822 - Backend creation cleanup and Database UI tab error handling (#6823)\n * Issue 6782 - Improve paged result locking\n * Issue 6825 - RootDN Access Control Plugin with wildcards for IP addre... (#6826)\n * Issue 6736 - Exception thrown by dsconf instance repl get_ruv (#6742)\n * Issue 6819 - Incorrect pwdpolicysubentry returned for an entry with user password policy\n * Issue 6553 - Update concread to 0.5.6 (#6824)\n * Issue 1081 - Add a CI test (#6063)\n * Issue 6761 - Password modify extended operation should skip password policy checks when executed by root DN\n * Issue 6791 - crash in liblmdb during instance shutdown (#6793)\n * Issue 6641 - modrdn fails when a user is member of multiple groups (#6643)\n * Issue 6776 - Enabling audit log makes slapd coredump\n * Issue 6534 - CI fails with Fedora 41 and DNF5\n * Issue 6787 - Improve error message when bulk import connection is closed\n * Issue 6727 - RFE - database compaction interval should be persistent\n * Issue 6438 - Add basic dsidm organizational unit tests\n * Issue 6439 - Fix dsidm service get_dn option\n * Issue 5120 - ns-slapd doesn't start in referral mode (#6763)\n","modified":"2026-04-02T17:24:31.604841Z","published":"2026-03-24T17:50:31Z","related":["CVE-2025-14905"],"upstream":["CVE-2025-14905"],"references":[{"type":"ADVISORY","url":"https://www.suse.com/support/update/announcement/2026/suse-su-202620927-1/"},{"type":"REPORT","url":"https://bugzilla.suse.com/1258727"},{"type":"WEB","url":"https://www.suse.com/security/cve/CVE-2025-14905"}],"affected":[{"package":{"name":"389-ds","ecosystem":"SUSE:Linux Enterprise Server 16.0","purl":"pkg:rpm/suse/389-ds&distro=SUSE%20Linux%20Enterprise%20Server%2016.0"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.0.6~git249.6688af9b2-160000.1.1"}]}],"ecosystem_specific":{"binaries":[{"389-ds":"3.0.6~git249.6688af9b2-160000.1.1","lib389":"3.0.6~git249.6688af9b2-160000.1.1","libsvrcore0":"3.0.6~git249.6688af9b2-160000.1.1","389-ds-devel":"3.0.6~git249.6688af9b2-160000.1.1","389-ds-snmp":"3.0.6~git249.6688af9b2-160000.1.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2026:20927-1.json"}},{"package":{"name":"389-ds","ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","purl":"pkg:rpm/suse/389-ds&distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.0.6~git249.6688af9b2-160000.1.1"}]}],"ecosystem_specific":{"binaries":[{"389-ds-devel":"3.0.6~git249.6688af9b2-160000.1.1","389-ds-snmp":"3.0.6~git249.6688af9b2-160000.1.1","389-ds":"3.0.6~git249.6688af9b2-160000.1.1","lib389":"3.0.6~git249.6688af9b2-160000.1.1","libsvrcore0":"3.0.6~git249.6688af9b2-160000.1.1"}]},"database_specific":{"source":"https://ftp.suse.com/pub/projects/security/osv/SUSE-SU-2026:20927-1.json"}}],"schema_version":"1.7.5"}