{"id":"AZL-95687","summary":"CVE-2026-14670 affecting package postgresql for versions less than 16.15-1","details":"Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body.  Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.","modified":"2026-09-10T14:16:59.289586737Z","published":"2026-08-13T13:17:44Z","upstream":["CVE-2026-14670"],"references":[{"type":"WEB","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-14670"}],"affected":[{"package":{"name":"postgresql","ecosystem":"Azure Linux:3","purl":"pkg:rpm/azure-linux/postgresql"},"ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"16.15-1"}]}],"database_specific":{"source":"https://github.com/microsoft/AzureLinuxVulnerabilityData/blob/main/osv/AZL-95687.json"}}],"schema_version":"1.9.0"}